Situation: We recently moved our site to HTTPS, and noticed that the C2C widget is being blocked by some browsers (e.g. Chrome Version 23.0.1271.64) as insecure content. This is breaking the support functionality. Can you please suggest on how to go about this issue?

 


Answer: "Iframe" is the answer. Put the c2c widget inside an http iframe.